Smart Youtube WordPress Plugin

Guys I am really sorry but I am not able to provide support for this plugin. That's the "price" of it being free. Most of the things you think don't work, really work, please check the documentation before you despair :)

Smart Youtube is a WordPress Video plugin that allows you to easily insert videos/playlists into your post, comments and in your RSS feed. The plugin is designed to be small and fast and not use any external resources.

Smart Youtube is one of the most popular WordPress plugins, with more than 1,000,000 downloads.

From version 4.0 Smart Youtube changed the name to Smart Youtube PRO and now also supports playback of Youtube, Vimeo, Metacafe, Liveleak and Facebook high quality videos, works on iPhone&iPad, produces xHTML valid code (unlike YouTube embed code), allows you to view videos in fullscreen, has robust widget support and much more.

The videos will be embedded in your RSS feed as well, and if this is not support by the reader you can choose to have video link and/or video preview screenshot displayed instead.

Main Features

  • Easily embeds YouTube, Vimeo, Metacafe, Liveleak and Facebook videos (normal/HD mode)
  • Works on iPhone, iPad and iPod
  • Embed YouTube playlist (normal/HD)
  • Supports latest high quality video protocols (360p and HD quality 720p)
  • Allows full YouTube customization (colors, border, size, full screen...)
  • Supports video deep linking (starting at desired point with &start=time parameter)
  • Supports migrated blogs from WordPress.com
  • Supports migration from other Youtube plugins such as wp-youtube
  • Extract video thumbnails in your archive/category posts
  • Provides a sidebar widget for videos as well
  • Produces xHTML valid code
  • Very fast and light, no extra scripts needed

Example

You can discuss all plugin related issues in the wordpress plugin forums.

 

Screenshot

Download

Installation & Usage

  1. Upload the whole plugin folder to your /wp-content/plugins/ folder.
  2. Go to the Plugins page and activate the plugin.
  3. Use the Options page to change RSS feed options
  4. When you want to display Youtube video in your post, paste the video link with httpv:// (notice the 'v')

Example: httpv://www.youtube.com/watch?v=00000000

0000000 part is your video REF#

The video will be automatically embedded to your post in the proper way.

If you want to post a high/HD (DVD quality, 720p) quality video you would use httpvh:// ('vh' for video high resolution)

To embed a playlist use extension 'vp' (eg. httpvp://www.youtube.com/view_play_list?p=528026B4F7B34094)

To use video deep linking just add &start=time parameter at the end of url. For example httpv://www.youtube.com/watch?v=OWfksMD4PAg&start=30 will start the video 30 seconds in.

Additionally, you can set how do you want the video to be displayed in your RSS feed. Smart Youtube can show the preview image of the video (automatically grabbed from Youtube), the link to the video, or both. I recommend enabling only the preview image.

Vimeo

httpv://vimeo.com/27287078

Metacafe

httpvh://vww.metacafe.com/watch/7815470/harry_potter_and_the_deathly_hallows_dvd_interview/

Liveleak

httpv://www.liveleak.com/view?i=cad_1322822486

Changelog

= 4.0 =
* Major release
* Added support for Vimeo, Metacafe, Liveleak and Facebook videos
* Now parses http:// and httpv:// videos jsut the same
* Option to autoplay only the first video on the page
* Exctract Video thumbnails
* Show video is Colorbox
* New much better, sidebar Widget support

= 3.9.1 =

Support for WiziApp.

= 3.8 =
* Support for new IFRAME embed code
* Support for HD playlists (httpvhp)
* Support for new play formats (1280x745 & 960x745)

v3.5

- Changes to Iphone video embed

Extra

1047 Comments

  1. Jul 16th, 2011

    Hey! When I started a blog for my friends about 2 years ago, I used this plug-in for embedding youtube videos. It worked out really well for a while and was very easy to use . The problem is, it's stopped working over the last few months. Now is the first chance I've had to be able to research how to fix it. Performing the updates doesn't help and something seems to be broken, although I can't figure out what. Here's the deal: When attempting to embed a video in a post using the WordPress GUI, you can no longer see the box that shows you where the video is located, making you unable to center or adjust the video in any way. The pre-existing posts still show up, and you can still add a video as well, you just can't see what you're doing when you add it, making it less-than-ideal and frustrating. I'm unsure if I should uninstall my current 3.8.8 version of the plug-in and then re-install it, or if that will only make things worse for me (breaking pre-existing videos on the site, etc). I would really appreciate any help that I could get fixing this, since it's the only thing that's impeding the functionality of my site at the moment. If more information is needed for an answer, please ask me the questions, because I'd really like to take care of this issue. I look forward to any response that may point me in the right direction. Thank you!

  2. Ben
    Jul 16th, 2011

    Vladimir, could you please include YouTube's new dark COSMIC PANDA THEME into the plugin.

    I've already written the code, all the necessary changes you need to make are listed here:
    http://wordpress.org/support/topic/youtubes-new-cosmic-panda-theme-dark?replies=1

    Great plugin, thanks so much!
    -Ben-

    • Jul 16th, 2011

      Hi Ben please feel free to send me the patched code - thanks :)

  3. Jul 15th, 2011

    First of all, I have been using the Smart Youtube plugin for quite some time now and I love it! But I do have (small) issue.

    When enabling the feature "Use IFRAME embed code (recommended)" the player defaults to the 360p video, even when using the httpvh code. When disabling the IFRAME option, its defaults to 720p video when using httpvh which it is supposed to do.

    It would also be nice though, to have an option to select the default video quality when using httpv/httpvh because we often embed game "preview" videos which are also available in 1080p.

  4. Jul 13th, 2011

    Don't think playlists are working on iOS devices. IFRAME is turned on, xHTML validation is turned off.

    Here's what's in the post:

    httpvp://www.youtube.com/view_play_list?p=89FE58FBF7FC704F

    This works fine in FireFox 5, Chrome 12, Safari 5, and IE 9 on Windows 7. Also works on Safari 5, Firefox 6 on Snow Leopard.

    However, I just get a blank (background colored) block on both iPad and iPhone 4. Latest iOS. Standard Twenty Eleven 1.2 theme on WP 3.2.1

    Thanks!

  5. Nic
    Jul 13th, 2011

    Hi,

    Great plugin. Does exactly what I wanted.

    I don't see videos in my RSS Feed, but I'm not overly bothered by that.

    I added to my {video} field...

    It worked, but now there's a grey border around the video in FireFox. Some Googling revealed that I need to add wmode="transparent" to the YT code. Can anyone tell me where to add this in, please?

    Thanks.

  6. Jul 8th, 2011

    Before I switched to Smart YouTube I was using another plugin to embed YouTube videos with custom code "tube".

    As mentioned in the plugin setting (*Smart YouTube) I entered the custom code in the text box but it doesn't embed and stays text.

    EXAMPLE: [tube]http://www.youtube.com/watch?v=CI3GrHBdZOI[/tube]

  7. Franck
    Jul 3rd, 2011

    Hi! thanks for this plugin. Unfortunately, no image at all is displayed in the feed (via Firefox), whether the post is a Youtube video, whether it's an image, not thumbnail or image in the rss feed.
    The option is checked in the plugin option. I tried checking/unchecking the xml option too, but nothing changes.
    What am i doing wrong?
    Thanks!

  8. Fraa
    Jul 2nd, 2011

    Is it possible to display (generate) a thumbnail of the video?
    I use a theme that displays a thumbnail of each post on the homepage so when the post is a video, that space is left blank...
    Thanks!

  9. Lucy
    Jul 2nd, 2011

    Hi Valdimir,

    I love your plugin its great!

    Just wondering if it would ever be possible to "lazy load" embedded videos so that they only appear when they can actually be seen, as this would help to improve page load speed.

  10. Polux
    Jul 2nd, 2011

    Hello,
    Your plugin is great but I miss one option: autohide controls. Is it possible to integrate it in a future release?
    Thank you for your excellent work!

  11. Jun 28th, 2011

    Is there a way to make the preview image in the RSS feed link back to the blog post instead of youtube?

  12. matthew
    Jun 23rd, 2011

    I am using the custom field template to create a TinyMCE field, but when I add the shortcode for the "smart youtube" plugin the httpv:// isn't converted into a youtube video.

    Is there a fix for this?

    Many thanks in advance,

    Matt.

  13. Jun 20th, 2011

    Any chance of adding support for the new logoless player feature?

    http://youtube-global.blogspot.com/2011/06/next-step-in-embedded-videos-hd-preview.html

    Thanks for your awesome work on the plugin!

  14. Jun 20th, 2011

    Drop down menus are behind YouTube video instead of on top of YouTube video. Is there a fix for this?

    • Jun 20th, 2011

      Yes here the same with Highslide Photos

      hope there's a fix for it...

  15. Jun 15th, 2011

    Hello, I really like your plugin.
    I am however unable to get youtube videos to loop when the IFRAME option is selected. Youtube videos loop just fine when the IFrame option is not selected. I prefer the look of the videos in IFrame, so that is why I am asking. Any suggestions.
    Also, on the iPhone youtube videos are not looping with or without the IFrame option selected. Not sure if that is normal

    Thank you for your time.

  16. west
    Jun 12th, 2011

    Your plug in does not allow for youtube annotations to appear. Because of this, I cannot use it. Will you have a plugin that allows annotations?

  17. Jun 9th, 2011

    Hello,

    Videos show "related videos" even though "Do not include related videos" is selected. This is happening only when the "Use IFRAME embed code (recommended)" is selected. Related videos do not show up when the IFRAME code is not selected. I am using the latest version 3.8.8. Thank you for your help.

  18. Jun 6th, 2011

    Hey, I love this plugin! Its ease of use and SEO optimization can't be beat. Thanks for the great work!

  19. Jun 5th, 2011

    Vladimir, good day and, first of all, many thanks for your plugin, I use it a lot on my blog.

    I have many posts and smart youtube works great, except (and from a few days only) for
    one video that once was displayed in the correct way but now does not load, the problem
    looks the same of Adam (message of two days ago), it is the two dashes: --

    Here is the url that does not embed:
    httpvh://www.youtube.com/watch?v=u_ohQV--Pyw&hd=1

    You can see it in this post (see at the half bottom of the page, there are two video,
    this first one video with the two dashes remain a url only white the second video
    at the very bottom has no problem, load and run correcly, it has no dashes):
    http://travelourplanet.com/destinations/central-america-and-caribbean/harbour-island-e-le-spiagge-di-north-eleuthera

    Please pay attention to one thing: iIf I put two times the underscore: _ _ just after the
    tho dashes -- well, smart you tube load , but of course as the url is wrong it can not
    display the video.

    I hope you can help and fix the problem! A lot of thanks.

    • Jun 5th, 2011

      Hi Fabio

      I will have a look and update the plugin if necessary.

    • Jul 1st, 2011

      Hi Fabio
      In your comment you say that you use smart tube on many posts. The problem im having is that i only seem to be able to use the plugin in one sidebar.

      I have several custom sidebars that need different video's

      After using it once it doesn't show in my list of widgets.

      Just wondered if you could help?

      Thanks

  20. Adam
    Jun 3rd, 2011

    Hi Vladimir,

    First of all, thanks so much for this plugin!

    I've noticed something that doesn't want to work for some reason.
    If I have this tag, it doesn't embed, stays text:
    [vid]I25Mb--4wGY[/vid]
    It must be an issue with the two dashes.

    Can you help me fix this?
    Thanks so much!

    • Jun 3rd, 2011

      Did you enter vid in the customcode box in the options?

      • Adam
        Jun 3rd, 2011

        Yes, but it doesn't work with the httpv solution either. :(
        It just doesn't like my two hyphens, whatever I do.

  21. Jun 2nd, 2011

    Thanks for fixing the problem so quickly.

  22. Jun 2nd, 2011

    Good news, the issue is fixed. Please update to 3.8.8.

    • PunK
      Jun 2nd, 2011

      thanks so quick action :) updating nw

    • Adam
      Jun 3rd, 2011

      Hi Vladimir,

      First of all, thanks so much for this plugin!

      I've noticed something that doesn't want to work for some reason.
      If I have this tag, it doesn't embed, stays text:
      [vid]I25Mb--4wGY[/vid]
      It must be an issue with the two dashes.

      Can you help me fix this?
      Thanks so much!

  23. Jun 2nd, 2011

    I have confirmed the change in Youtube behavior, will update the plugin as soon as find the problem.

  24. PunK
    Jun 2nd, 2011

    Hey ! after latest update of plugin it stoped using the settings as per options panel
    earlier i used to off autoplay
    nw also autoplay is off but its still autoplaying the videos & player color change to orange also not effecting appearance !!!

    • Jun 2nd, 2011

      I am having the same problem - I cannot get it to STOP Autoplay...any ideas???

  25. Hoteliertanji
    Jun 2nd, 2011

    Hello have you noticed that from today all embaded videos that were embaded with this plugin start autoplaying while disabling autoplay option. I have been using this plugin for around a year but just from today I am experiencing all my embaded Youtube videos are autoplaying which is really frustrating. Is it happened due to any change in youtube? Please solve the issue

Have your say

Your email is never published nor shared. Required fields are marked *

*
*

  • ManageWP